Origami Frontend Components & Services

Details: o-gallery

Required Browser Features

o-gallery@^3.0.8 requires the following browser features:

Optional Browser Features

o-gallery@^3.0.8 works best for browsers which support the following features, but will handle cases where they are not avalible:

We recommend polyfill.io to add support for missing features to older browsers.

Bower Dependencies

Dependency Version
o-icons ^4.1.0 <6
o-colors ^4.0.0
ftscroller https://github.com/ftlabs/ftscroller.git#^0.6.0
o-viewport >=0.1.1 <4.0.0
ftdomdelegate >=2.2.0 <4.0.0
Switch component view

GitHub Repository

Install o-gallery

If using the Build Service, add o-gallery@^3.0.8 to your script and link tags.

If running a Manual Build, run bower install --save "o-gallery@^3.0.8".

Help & Support

o-gallery is maintained directly by the Origami team. If you have any questions about o-gallery or Origami in general, we are happy to help. 😊

Slack: #ft-origami
Email: origami.support@ft.com

Feedback / Issues

To report a bug or request features please create an issue on Github. For support or general feedback please get in touch 😊

Slack: #ft-origami
Email: origami.support@ft.com