Origami Frontend Components & Services

Details: o-typography

Optional Browser Features

o-typography@^6.4.6 works best for browsers which support the following features, but will handle cases where they are not avalible:

We recommend polyfill.io to add support for missing features to older browsers.

Bower Dependencies

Dependency Version
o-grid ^5.0.0
o-fonts ^4.5.0
o-icons ^6.0.0
o-colors ^5.0.0
o-spacing ^2.0.0
o-normalise ^2.0.0
fontfaceobserver ^2.0.9
Status
active Origami v1 (Bower)
Switch component view

GitHub Repository

Install o-typography

If using the Build Service, add o-typography@^6.4.6 to your script and link tags.

If using the npm package manager for a Manual Build, run npm install --save-peer "@financial-times/o-typography@^6.4.6".

Help & Support

o-typography is maintained directly by the Origami team. If you have any questions about o-typography or Origami in general, we are happy to help. 😊

Slack: #origami-support
Email: origami.support@ft.com

Feedback / Issues

To report a bug or request features please create an issue on Github. For support or general feedback please get in touch 😊

Slack: #origami-support
Email: origami.support@ft.com